#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?!^)(?=[A-Z][a-z]+|(?<=\D)\d)"
Local $sString = "SomeEquipmentHere" & @CRLF & _
"ABSBrakes" & @CRLF & _
"CDRadio" & @CRLF & _
"Valve14" & @CRLF & _
"AC-DC" & @CRLF & _
"WTF" & @CRLF & _
"ROTFLMAO" & @CRLF & _
"ServiceOK" & @CRLF & _
"ESP"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)