using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!^)(?=[A-Z][a-z]+|(?<=\D)\d)";
string substitution = @" ";
string input = @"SomeEquipmentHere
ABSBrakes
CDRadio
Valve14
AC-DC
WTF
ROTFLMAO
ServiceOK
ESP";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}