use strict;
my $str = 'SomeEquipmentHere
ABSBrakes
CDRadio
Valve14
AC-DC
WTF
ROTFLMAO
ServiceOK
ESP';
my $regex = qr/(?!^)(?=[A-Z][a-z]+|(?<=\D)\d)/mp;
my $subst = ' ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";