import Foundation
let pattern = #"(?!^)(?=[A-Z][a-z]+|(?<=\D)\d)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
SomeEquipmentHere
ABSBrakes
CDRadio
Valve14
AC-DC
WTF
ROTFLMAO
ServiceOK
ESP
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)