#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=(Weight|Wt\.) ?\(kg\) : )\d+\.\d+(?= Kg)"
Local $sString = "Weight (kg) : 2.0 Kg" & @CRLF & _
"Wt. (kg) : 2.2 Kg" & @CRLF & _
"Weight(kg) : 1.5 Kg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")