import re
regex = re.compile(r"(?<=(Weight|Wt\.) ?\(kg\) : )\d+\.\d+(?= Kg)", flags=re.MULTILINE)
test_str = ("Weight (kg) : 2.0 Kg\n"
"Wt. (kg) : 2.2 Kg\n"
"Weight(kg) : 1.5 Kg")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")