$re = '/(?<=(Weight|Wt\.) ?\(kg\) : )\d+\.\d+(?= Kg)/m';
$str = 'Weight (kg) : 2.0 Kg
Wt. (kg) : 2.2 Kg
Weight(kg) : 1.5 Kg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);