using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Za-z0-9\x{0900}-\x{097F}\-\/ ]+";
string input = @"गुढ़ी पाडवा/चेती चंद / उगाड ी / Gudi Padwa/Cheti Chand / Ugadi";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}