re = /[A-Za-z0-9\x{0900}-\x{097F}\-\/ ]+/m
str = 'गुढ़ी पाडवा/चेती चंद / उगाडी / Gudi Padwa/Cheti Chand / Ugadi'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end