// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[A-Za-z0-9\x{0900}-\x{097F}\-\/ ]+").unwrap();
let string = "गुढ़ी पाडवा/चेती चंद / उगाडी / Gudi Padwa/Cheti Chand / Ugadi";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}