$re = '/[A-Za-z0-9\x{0900}-\x{097F}\-\/ ]+/m';
$str = 'गुढ़ी पाडवा/चेती चंद / उगाडी / Gudi Padwa/Cheti Chand / Ugadi';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);