const regex = /([a-z-_0-9/:.]*.(jpg|jpeg|png|gif))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-z-_0-9\/:.]*.(jpg|jpeg|png|gif))', 'gm')
const str = `<img src="https://i.etsystatic.com/50991663/r/il/dd21f9/5845721064/il_570xN.5845721064_lot1.jpg" border="0"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}