$re = '/([a-z-_0-9/:.]*.(jpg|jpeg|png|gif))/m';
$str = '<img src="https://i.etsystatic.com/50991663/r/il/dd21f9/5845721064/il_570xN.5845721064_lot1.jpg" border="0"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);