use strict;
my $str = '<img src="https://i.etsystatic.com/50991663/r/il/dd21f9/5845721064/il_570xN.5845721064_lot1.jpg" border="0"';
my $regex = qr/([a-z-_0-9/:.]*.(jpg|jpeg|png|gif))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}