// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([a-z-_0-9/:.]*.(jpg|jpeg|png|gif))").unwrap();
let string = "<img src=\"https://i.etsystatic.com/50991663/r/il/dd21f9/5845721064/il_570xN.5845721064_lot1.jpg\" border=\"0\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}