import re
regex = re.compile(r"([a-z-_0-9/:.]*.(jpg|jpeg|png|gif))", flags=re.MULTILINE)
test_str = "<img src=\"https://i.etsystatic.com/50991663/r/il/dd21f9/5845721064/il_570xN.5845721064_lot1.jpg\" border=\"0\""
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")