using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<url>https.*)\/"",""text"":""(?<text>.*)"",";
string input = @"""test"":{""url"":""https://domain.ru/"",""text"":""name"",""params"":{}},""test"": ""url"":""https://domain2.ru/"",""text"":""name2"",""params"":{}},";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}