package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mU)(?<url>https.*)\/","text":"(?<text>.*)",`)
var str = `"test":{"url":"https://domain.ru/","text":"name","params":{}},"test": "url":"https://domain2.ru/","text":"name2","params":{}},`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}