$re = '/(?<url>https.*)\/","text":"(?<text>.*)",/mU';
$str = '"test":{"url":"https://domain.ru/","text":"name","params":{}},"test": "url":"https://domain2.ru/","text":"name2","params":{}},';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);