// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mU)(?<url>https.*)\/","text":"(?<text>.*)","#).unwrap();
let string = "\"test\":{\"url\":\"https://domain.ru/\",\"text\":\"name\",\"params\":{}},\"test\": \"url\":\"https://domain2.ru/\",\"text\":\"name2\",\"params\":{}},";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}