const regex = /(?<url>https.*)\/","text":"(?<text>.*)",/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<url>https.*)\\\/","text":"(?<text>.*)",', 'gm')
const str = `"test":{"url":"https://domain.ru/","text":"name","params":{}},"test": "url":"https://domain2.ru/","text":"name2","params":{}},`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}