#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=Invoice No\.\s).*|(?<=Job\r?\n).*(?=\sPage)"
Local $sString = "Invoice No. 7334/00148461" & @CRLF & _
"" & @CRLF & _
"Job" & @CRLF & _
"994 HUNTERS HILL Page 1 of 1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")