re = /(?<=Invoice No\.\s).*|(?<=Job\r?\n).*(?=\sPage)/m
str = 'Invoice No. 7334/00148461
Job
994 HUNTERS HILL Page 1 of 1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end