import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=Invoice No\\.\\s).*|(?<=Job\\r?\\n).*(?=\\sPage)";
final String string = "Invoice No. 7334/00148461\n\n"
+ "Job\n"
+ "994 HUNTERS HILL Page 1 of 1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}