const regex = /(?<=Invoice No\.\s).*|(?<=Job\r?\n).*(?=\sPage)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Invoice No\\.\\s).*|(?<=Job\\r?\\n).*(?=\\sPage)', 'gm')
const str = `Invoice No. 7334/00148461
Job
994 HUNTERS HILL Page 1 of 1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}