$re = '/(?<=Invoice No\.\s).*|(?<=Job\r?\n).*(?=\sPage)/m';
$str = 'Invoice No. 7334/00148461
Job
994 HUNTERS HILL Page 1 of 1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);