using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(NF\s?EN)?\s?ISO\s?\d{3,6}(:?\d{1,4})?-?\d?";
string input = @"VAS H M1582/950-80 ABCDFEF - ISO4014";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}