re = /(NF\s?EN)?\s?ISO\s?\d{3,6}(:?\d{1,4})?-?\d?/m
str = 'VAS H M1582/950-80 ABCDFEF - ISO4014'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end