package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(NF\s?EN)?\s?ISO\s?\d{3,6}(:?\d{1,4})?-?\d?`)
var str = `VAS H M1582/950-80 ABCDFEF - ISO4014`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}