$re = '/(NF\s?EN)?\s?ISO\s?\d{3,6}(:?\d{1,4})?-?\d?/m';
$str = 'VAS H M1582/950-80 ABCDFEF - ISO4014';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);