// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(NF\s?EN)?\s?ISO\s?\d{3,6}(:?\d{1,4})?-?\d?").unwrap();
let string = "VAS H M1582/950-80 ABCDFEF - ISO4014";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}