#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?:https?:\/\/)?(?:(?:www|gaming)\.)?youtube\.com\/(?:channel\/|(?:c\/)|(?:user\/)?)([a-z\-_0-9]+)\/?(?:[\?#]?.*)"
Local $sString = "https://www.youtube.com/c/LeSanctuaireNotreDamedeLourdes/zef" & @CRLF & _
"https://www.youtube.com/channel/UC7zlbnNCnuAPiC3goKcFgUg/zefzf" & @CRLF & _
"https://www.youtube.com/user/IciJapon/zefzef" & @CRLF & _
"https://www.youtube.com/IciJapon" & @CRLF & _
"https://www.youtube.com/c/LudovicBvideos" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")