// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(?:https?:\/\/)?(?:(?:www|gaming)\.)?youtube\.com\/(?:channel\/|(?:c\/)|(?:user\/)?)([a-z\-_0-9]+)\/?(?:[\?#]?.*)").unwrap();
let string = "https://www.youtube.com/c/LeSanctuaireNotreDamedeLourdes/zef
https://www.youtube.com/channel/UC7zlbnNCnuAPiC3goKcFgUg/zefzf
https://www.youtube.com/user/IciJapon/zefzef
https://www.youtube.com/IciJapon
https://www.youtube.com/c/LudovicBvideos
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}