package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?:https?:\/\/)?(?:(?:www|gaming)\.)?youtube\.com\/(?:channel\/|(?:c\/)|(?:user\/)?)([a-z\-_0-9]+)\/?(?:[\?#]?.*)`)
var str = `https://www.youtube.com/c/LeSanctuaireNotreDamedeLourdes/zef
https://www.youtube.com/channel/UC7zlbnNCnuAPiC3goKcFgUg/zefzf
https://www.youtube.com/user/IciJapon/zefzef
https://www.youtube.com/IciJapon
https://www.youtube.com/c/LudovicBvideos
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}