import Foundation
let pattern = ##"^(?:https?:\/\/)?(?:(?:www|gaming)\.)?youtube\.com\/(?:channel\/|(?:c\/)|(?:user\/)?)([a-z\-_0-9]+)\/?(?:[\?#]?.*)"##
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
https://www.youtube.com/c/LeSanctuaireNotreDamedeLourdes/zef
https://www.youtube.com/channel/UC7zlbnNCnuAPiC3goKcFgUg/zefzf
https://www.youtube.com/user/IciJapon/zefzef
https://www.youtube.com/IciJapon
https://www.youtube.com/c/LudovicBvideos
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)