using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(node_modules\/(?!is-online)\/(?!public-ip)|bower_components)";
string input = @"./node_modules/
./node_modules//
./node_modules/random-module
./node_modules//random-module
./node_modules/is-online
./node_modules/is-online/foo
./node_modules//public-ip
./node_modules//public-ip/bar
./node_modules/is-online/public-ip
./node_modules/is-online/public-ip/
./bower_components
./bower_components/is-online/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}