import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(node_modules\\/(?!is-online)\\/(?!public-ip)|bower_components)";
final String string = "./node_modules/\n"
+ "./node_modules//\n"
+ "./node_modules/random-module\n"
+ "./node_modules//random-module\n"
+ "./node_modules/is-online\n"
+ "./node_modules/is-online/foo\n"
+ "./node_modules//public-ip\n"
+ "./node_modules//public-ip/bar\n"
+ "./node_modules/is-online/public-ip\n"
+ "./node_modules/is-online/public-ip/\n"
+ "./bower_components\n"
+ "./bower_components/is-online/";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}