$re = '/(node_modules\/(?!is-online)\/(?!public-ip)|bower_components)/m';
$str = './node_modules/
./node_modules//
./node_modules/random-module
./node_modules//random-module
./node_modules/is-online
./node_modules/is-online/foo
./node_modules//public-ip
./node_modules//public-ip/bar
./node_modules/is-online/public-ip
./node_modules/is-online/public-ip/
./bower_components
./bower_components/is-online/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);