use strict;
my $str = './node_modules/
./node_modules//
./node_modules/random-module
./node_modules//random-module
./node_modules/is-online
./node_modules/is-online/foo
./node_modules//public-ip
./node_modules//public-ip/bar
./node_modules/is-online/public-ip
./node_modules/is-online/public-ip/
./bower_components
./bower_components/is-online/';
my $regex = qr/(node_modules\/(?!is-online)\/(?!public-ip)|bower_components)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}