import Foundation
let pattern = #"(node_modules\/(?!is-online)\/(?!public-ip)|bower_components)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
./node_modules/
./node_modules//
./node_modules/random-module
./node_modules//random-module
./node_modules/is-online
./node_modules/is-online/foo
./node_modules//public-ip
./node_modules//public-ip/bar
./node_modules/is-online/public-ip
./node_modules/is-online/public-ip/
./bower_components
./bower_components/is-online/
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)