package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?is)<!--(.*?)-->|<(?P<tag>[a-z0-9]+?)[^>]*>.*?<\/(?P=tag)>|<([a-z0-9]+).*?\/>|[\S ]+`)
var str = `<!--comment1
-->
<h1>header</h1>
<img src="http://example.com/img.png" title="single tag"/>
<p>long text</p>
<img src="http://example.com/img2.png"
title="single tag"/>
<!-- comment1 -->
<ul>
<li>item1</li>
<li>item2</li>
<li>item3</li>
</ul>
some text
<br class="unclosed">
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}