re = /<!--(.*?)-->|<(?P<tag>[a-z0-9]+?)[^>]*>.*?<\/(?P=tag)>|<([a-z0-9]+).*?\/>|[\S ]+/i
str = '<!--comment1
-->
<h1>header</h1>
<img src="http://example.com/img.png" title="single tag"/>
<p>long text</p>
<img src="http://example.com/img2.png"
title="single tag"/>
<!-- comment1 -->
<ul>
<li>item1</li>
<li>item2</li>
<li>item3</li>
</ul>
some text
<br class="unclosed">
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end