import re
regex = re.compile(r"<!--(.*?)-->|<(?P<tag>[a-z0-9]+?)[^>]*>.*?<\/(?P=tag)>|<([a-z0-9]+).*?\/>|[\S ]+", flags=re.IGNORECASE | re.DOTALL)
test_str = ("<!--comment1\n"
" -->\n"
"<h1>header</h1>\n\n"
"<img src=\"http://example.com/img.png\" title=\"single tag\"/>\n\n"
"<p>long text</p>\n\n"
"<img src=\"http://example.com/img2.png\"\n"
" title=\"single tag\"/>\n\n"
" \n\n"
" \n"
"<!-- comment1 -->\n"
"<ul>\n"
" <li>item1</li>\n"
" <li>item2</li>\n"
" <li>item3</li>\n"
"</ul>\n\n"
" \n"
"some text\n"
" \n\n\n"
"<br class=\"unclosed\">\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")