const regex = /<!--(.*?)-->|<(?P<tag>[a-z0-9]+?)[^>]*>.*?<\/(?P=tag)>|<([a-z0-9]+).*?\/>|[\S ]+/gis;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<!--(.*?)-->|<(?P<tag>[a-z0-9]+?)[^>]*>.*?<\\\/(?P=tag)>|<([a-z0-9]+).*?\\\/>|[\\S ]+', 'gis')
const str = `<!--comment1
-->
<h1>header</h1>
<img src="http://example.com/img.png" title="single tag"/>
<p>long text</p>
<img src="http://example.com/img2.png"
title="single tag"/>
<!-- comment1 -->
<ul>
<li>item1</li>
<li>item2</li>
<li>item3</li>
</ul>
some text
<br class="unclosed">
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}