using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" [0-9]{3}x[0-9]{3} ";
string input = @"kbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyr
kbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyrkbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyrkbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyrkbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyrkbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyrkbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyrkbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyr";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}