import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " [0-9]{3}x[0-9]{3} ";
final String string = "kbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyr\n"
+ "kbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyrkbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyrkbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyrkbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyrkbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyrkbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyrkbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyr";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}