// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r" [0-9]{3}x[0-9]{3} ").unwrap();
let string = "kbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyr
kbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyrkbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyrkbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyrkbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyrkbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyrkbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyrkbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyr";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}