$re = '/ [0-9]{3}x[0-9]{3} /';
$str = 'kbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyr
kbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyrkbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyrkbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyrkbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyrkbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyrkbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyrkbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyr';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);