package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(` [0-9]{3}x[0-9]{3} `)
var str = `kbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyr
kbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyrkbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyrkbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyrkbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyrkbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyrkbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyrkbksngklmdf from 555x666 to 666x444 Saving cfbhjnhguvfyr`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}