#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?|(\?)|&)ordem=\d+(?(1)(&|$))"
Local $sString = "http://www.meudominio.com.br/pagina.php?campo=teste&cor=azul&ordem=2FFF"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)